Email notifications are limited

Incident Report for RevOps, Inc.

Resolved

This incident has been resolved
Posted Mar 26, 2025 - 15:47 UTC

Monitoring

RevOps platform is having trouble processing emails through their email provider
Posted Mar 26, 2025 - 13:55 UTC
This incident affected: RevOps Console.