Background jobs including PDF generation, and Slack and email notifications may be delayed

Incident Report for RevOps, Inc.

Resolved

Impacted deals and failed notifications have been updated and resend, respectively. All upstream providers are reporting resolved incidents and all of our previously degraded services are now completely restored.

If you have any questions or comments, or think you're still impacted, please reach out to us at support@revops.io
Posted Oct 21, 2025 - 01:38 UTC

Update

PDF Generation and all other background jobs have stabilized and are performing with no issues now.

We are also aware of issues with Slack and email notifications not being received, this is related to incidents from upstream providers. While Slack notification error rates are decreasing, email notification error rates are no long increasing. We will continue to monitor these services.

We are beginning investigation of impacted deals and failed notifications, and will update deals and resend notifications. If you are missing expected notifications, you will begin to receive them shortly.
Posted Oct 20, 2025 - 23:49 UTC

Monitoring

A change in our platform appears to be the root cause of the service degradation. We have rolled back the change and we are seeing a reduction in error rates. We will continue to monitor and update any impacted deals or other platform resources.
Posted Oct 20, 2025 - 23:15 UTC

Investigating

Service degradation issues for this morning seems to have re-appeared. We are currently investigating any impact to RevOps CPQ customers and taking steps to resolve the issues.
Posted Oct 20, 2025 - 22:29 UTC
This incident affected: RevOps Console and CRM Integrations (Salesforce Integration, HubSpot Integration).