DocuSign Esignature Outage
Incident Report for RevOps, Inc.
Resolved
This incident has been resolved.
Posted May 24, 2022 - 23:50 UTC
Update
All impacted esignature deals have been regenerated, and all services have been restored.
Posted May 24, 2022 - 23:49 UTC
Update
DocuSign's esigning is up and running again. We are working on recovering our system and will have it working at full capacity shortly.
Posted May 24, 2022 - 23:24 UTC
Update
DocuSign has confirmed the incident and has updated https://status.docusign.com/. We will continue to monitor and regenerate any failed envelopes once DocuSign recovers.

If you have any questions, please contact support@revops.io or via Slack Connect.
Posted May 24, 2022 - 19:33 UTC
Identified
We have identified the source of the issue and have moved into esignature maintenance mode. We will continue to provide updates where possible while we work with DocuSign to resolve the issue.
Posted May 24, 2022 - 19:25 UTC
Investigating
We are currently investigating errors related to DocuSign esigning. We will provide further updates when possible.
Posted May 24, 2022 - 19:17 UTC
This incident affected: eSignature Operations (DocuSign Integration).