Our stable backup region is continuing to process events and we are seeing a complete reduction in error rates. All impacted deals and other resources have been successfully corrected or updated. We plan to roll over to our primary once the upstream degradation is resolved.
If you have any questions or comments, or if you think you're still impacted, please reach out to us at support@revops.io
Posted Oct 20, 2025 - 18:33 UTC
Monitoring
We've identified impact and have rolled over services to a stable backup region. We are beginning to see reduction in error rates for these services. We will continue monitoring as this event continues.
Posted Oct 20, 2025 - 18:03 UTC
Investigating
One of our infrastructure providers has reported service degradation, and we are currently investigating any impact to RevOps CPQ customers.
Posted Oct 20, 2025 - 17:43 UTC
This incident affected: RevOps Console and CRM Integrations (Salesforce Integration, HubSpot Integration).