Proposal page has an endlessly spinning button
Incident Report for RevOps, Inc.
Resolved
This incident has been resolved.
Posted Jul 05, 2022 - 17:56 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 05, 2022 - 17:41 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 05, 2022 - 17:30 UTC
Investigating
We are currently investigating the issue. The workaround is to enter in your email address into the field, and press enter or click on the endlessly spinning button to access the proposal.
Posted Jul 05, 2022 - 17:26 UTC
This incident affected: RevOps Console.