Maintenance Operation

Incident Report for RevOps, Inc.

Resolved

Maintenance operations have been completed.
Posted Jun 06, 2025 - 03:45 UTC

Investigating

We are performing a maintenance operation that may delay processing Deal events and third party integrations.
Posted Jun 05, 2025 - 22:30 UTC
This incident affected: CRM Integrations (Salesforce Integration), RevOps API, and Billing Integrations (Stripe Integration).